CVS difference for ai05s/ai05-0215-1.txt

Differences between 1.2 and version 1.3
Log of other versions for file ai05s/ai05-0215-1.txt

--- ai05s/ai05-0215-1.txt	2010/10/26 04:03:12	1.2
+++ ai05s/ai05-0215-1.txt	2011/01/27 06:06:17	1.3
@@ -169,3 +169,228 @@
     construct.
 
 ****************************************************************
+
+From: Bob Duff
+Sent: Sunday, January 23, 2011  2:35 PM
+
+...
+>     * AI05-0215-1 Suggest a better aspect name than "Implemented" [Nov.
+> phone meeting]
+
+I don't see anything about this in those minutes.
+But anyway, here's my suggested name changes (for the pragma and it allowed
+arguments):
+
+    Implemented --> Synchronized_Implementation
+    By_Entry --> Entry
+    By_Protected_Procedure --> Protected_Procedure
+    By_Any --> Any
+
+Or maybe just change the pragma name.
+
+****************************************************************
+
+From: John Barnes
+Sent: Sunday, January 23, 2011  4:15 PM
+
+Seems preferable as it is to me.
+
+****************************************************************
+
+From: Robert Dewar
+Sent: Sunday, January 23, 2011  5:37 PM
+
+>      Implemented -->  Synchronized_Implementation
+
+I find this much too long
+
+****************************************************************
+
+From: Bob Duff
+Sent: Sunday, January 23, 2011  5:46 PM
+
+Do you have a better idea?
+
+Does anybody remember why we wanted to change this name?
+I think it's because (1) "Implemented" is way to general a term for what this
+thing does, and (2) it doesn't read well as an aspect.  But I don't really
+remember the discussion. And I'm still ambivalent about shoe-horning everything
+under the Sun into "aspect" syntax.  The minutes don't clue me in.
+
+Anyway, I don't buy "too long", because it's rarely used.
+It will increase the total size of all Ada programs world wide by perhaps
+0.000_001%".  ;-)
+
+****************************************************************
+
+From: Robert Dewar
+Sent: Sunday, January 23, 2011  5:52 PM
+
+> Does anybody remember why we wanted to change this name?
+> I think it's because (1) "Implemented" is way to general a term for
+> what this thing does, and (2) it doesn't read well as an aspect.  But
+> I don't really remember the discussion.
+> And I'm still ambivalent about shoe-horning everything under the Sun
+> into "aspect" syntax.  The minutes don't clue me in.
+
+I think the current proposal is better than your proposed substitute.
+
+> Anyway, I don't buy "too long", because it's rarely used.
+> It will increase the total size of all Ada programs world wide by
+> perhaps 0.000_001%".  ;-)
+
+The fact that a nasty long name is not going to be used often is not a good
+enough justification for me.
+
+****************************************************************
+
+From: Randy Brukardt
+Sent: Monday, January 24, 2011  9:36 PM
+
+...
+> Does anybody remember why we wanted to change this name?
+
+My recollection is that you were the one that wanted to change it, so I would
+have hoped you remembered why. ;-)
+
+> I think it's because (1) "Implemented" is way to general a term for
+> what this thing does, and (2) it doesn't read well as an aspect.  But
+> I don't really remember the discussion.
+> And I'm still ambivalent about shoe-horning everything under the Sun
+> into "aspect" syntax.  The minutes don't clue me in.
+
+I think that sounds about right. "Implemented" doesn't seem to indicate at all
+what it is about. It's really "the overriding or implemented-by routine must be
+of this kind". "Implemented by" only is true for task and protected operations,
+and this definition is wider than that anyway.
+
+I think we were hoping that you would have a wonderful idea that's nice and
+short and descriptive. Part of the problem is that *Ada* doesn't have such a
+term, so it's asking a lot for something meaningful.
+
+Perhaps someone will have a better idea from these musings.
+
+****************************************************************
+
+From: Brad Moore
+Sent: Tuesday, January 25, 2011  8:33 AM
+
+> Perhaps someone will have a better idea from these musings.
+
+How about just Synchronized?  The word Implemented doesn't really add anything.
+Also, this allows us to get rid of  By_Any. If the pragma doesn't have an argument, that would be the By_Any case.
+
+     Implemented -->  Synchronized
+     By_Entry -->  Entry
+     By_Protected_Procedure -->  Protected_Procedure
+     By_Any -->
+
+****************************************************************
+
+From: Bob Duff
+Sent: Tuesday, January 25, 2011  8:45 AM
+
+> How about just Synchronized?  The word Implemented doesn't really add
+> anything.
+
+I like it.
+
+> Also, this allows us to get rid of  By_Any. If the pragma doesn't have
+> an argument, that would be the By_Any case.
+
+I'm not sure about that.  It's not intuitively obvious that "pragma
+Synchronized;" means "by-any".
+
+>      Implemented -->  Synchronized
+>      By_Entry -->  Entry
+>      By_Protected_Procedure -->  Protected_Procedure
+
+Agreed.
+
+>      By_Any -->
+
+I think I prefer "By_Any --> Any".
+
+OTOH, I'd be happy to keep the "By_" prefixes, if folks like them.  The main
+thing is to rename the pragma/aspect itself.
+
+****************************************************************
+
+From: Tucker Taft
+Sent: Tuesday, January 25, 2011  8:49 AM
+
+Unfortunately, both "synchronized" and "entry" are reserved words.
+
+Perhaps:
+
+Is_Synchronized => By_Entry
+Is_Synchronized => By_Protected_Procedure
+Is_Synchronized [=> True]
+Is_Synchronized => False
+
+****************************************************************
+
+From: Bob Duff
+Sent: Tuesday, January 25, 2011  8:59 AM
+
+> Unfortunately, both "synchronized" and "entry" are reserved words.
+
+I was thinking that's OK for pragmas.  But now I realize that if you want to
+make it an aspect, reserved words are a no-no.
+
+> Perhaps:
+>
+> Is_Synchronized => By_Entry
+> Is_Synchronized => By_Protected_Procedure Is_Synchronized [=> True]
+> Is_Synchronized => False
+
+Looks good.
+
+****************************************************************
+
+From: Brad Moore
+Sent: Tuesday, January 25, 2011  9:42 AM
+
+I suppose "synchronous" could be another alternative, that isn't a reserved
+word. If that were the case, is it just the aspect name that causes a problem?
+Or would the aspect qualifiers also present a problem if they conflict
+with reserved words.
+
+ie
+   pragma Synchronous (Entry);
+   pragma Synchronous (Protected_Procedure);
+
+     Synchronous => Entry
+     Synchronous => Protected_Procedure
+     Synchronous [=> True]
+     Syncrhonous => False;
+
+In any case, I'm not sure which I like better. They both look good to
+me, and an improvement over the pragma Implemented.
+
+****************************************************************
+
+From: John Barnes
+Sent: Tuesday, January 25, 2011  11:23 AM
+
+I am happy with Is_Synchronized and keeping By. I much prefer By_Any to True or
+False.  Having them all start By_ has a nice rhythm to it.
+
+By_Whatever, By_Any_Old_How, By_George...
+
+****************************************************************
+
+From: John Barnes
+Sent: Tuesday, January 25, 2011  2:02 PM
+
+I should have added By_Hook_Or_By_Crook.
+
+****************************************************************
+
+From: Edmond Schonberg
+Sent: Tuesday, January 25, 2011  3:36 PM
+
+Not to mention By_Mistake and By_Pure_Luck.
+
+****************************************************************
+

Questions? Ask the ACAA Technical Agent